Qmmp 音頻播放器 1.1.5 / 0.10.5 添加 FFmpeg 3.2 支持

Qmmp 是一款基於 Qt 的多媒體播放器,具有類似 Winamp 的界面,剛剛發布了 1.1.5(用於 Qt5)和 0.10.5(用於 Qt4)版本。

Qmmp 1.1.5 和 0.10.5 添加了對 FFmpeg 3.2 的支持,並修復了以下錯誤:

  • 修復http插件中的文件下載問題;
  • 修復 qsui 插件中的目錄選擇;
  • 修復可能的分段錯誤;
  • 修復命令行選項“–pl-repeat-toggle”;
  • 修復一些 cppcheck 警告;
  • 更改文件對話框形式。

如何在 Ubuntu 中安裝 Qmmp 1.1.5 / 0.10.5:

新版本已被製作成 官方 PPA

  • Qt 5 版本 (1.1.5) 可用於 Ubuntu 16.04、Ubuntu 16.10 和衍生產品。
  • Qt 4 版本 (0.10.5) 可用於 Ubuntu 12.04、Ubuntu 14.04、Ubuntu 16.04、Ubuntu 16.10。

要安裝它,請按照以下步驟操作:

1. 打開終端(Ctrl+Alt+T) 並運行命令以添加 PPA:

sudo add-apt-repository ppa:forkotov02/ppa

當它詢問並點擊時輸入您的密碼(沒有視覺反饋) Enter.

2. 要從以前的版本升級 Qmmp,請啟動 軟件更新程序 並在檢查更新後安裝更新。

升級 Qmmp 音樂播放器

或者通過命令在終端中安裝 /upgrade Qmmp:

sudo apt update && sudo apt install qmmp qmmp-plugin-pack

對於 Ubuntu 16.04、Ubuntu 16.10 用戶想要安裝 Qmmp 0.10.5(Qt4 版本),請改用以下命令:

sudo apt update && sudo apt install qmmp-qt4 qmmp-plugin-pack-qt4

卸載:

要將 Qmmp 降級到 Ubuntu 主存檔中可用的庫存版本,只需運行命令來清除 PPA:

sudo apt install ppa-purge && sudo ppa-purge ppa:forkotov02/ppa

如果要通過命令刪除 Qmmp 音頻播放器:

sudo apt remove qmmp qmmp-qt4 qmmp-plugin-pack qmmp-plugin-pack-qt4

並且可以通過系統設置 -> 軟件和更新 -> 其他軟件選項卡刪除 PPA 存儲庫。